import re
regex = re.compile(r"""
(?:[0-9]+|twitter|consectetur)(?![0-9a-z]*\[\/[a-z]+\])
""", flags=re.MULTILINE | re.IGNORECASE | re.VERBOSE)
test_str = "123456 Lorem ipsum [tel]123456[/tel] dolor sit [tw]@twitter[/tw] amet, consectetur adipiscing elit [a]example[/a]"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")