$re = '/^P5RNP\d{8}\/\d{5}S\d+\.\d{2}A$/';
$str = 'P5RNP15226660/01981S15851.22A';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);