import re
regex = re.compile(r"^P5RNP\d{8}\/\d{5}S\d+\.\d{2}A$")
test_str = "P5RNP15226660/01981S15851.22A"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")