const regex = /(?<day>0[1-9]|1[0-9]|2[0-9]|3[01]).(?<month>0[1-9]|1[012]).(?<year>[0-9]{4})(?: (?<hour>[0-1]\d|2[0-3]):(?<minute>[0-5]\d):(?<second>[0-5]\d)|)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<day>0[1-9]|1[0-9]|2[0-9]|3[01]).(?<month>0[1-9]|1[012]).(?<year>[0-9]{4})(?: (?<hour>[0-1]\\d|2[0-3]):(?<minute>[0-5]\\d):(?<second>[0-5]\\d)|)', '')
const str = `21.10.2013`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}