re = /(?<day>0[1-9]|1[0-9]|2[0-9]|3[01]).(?<month>0[1-9]|1[012]).(?<year>[0-9]{4})(?: (?<hour>[0-1]\d|2[0-3]):(?<minute>[0-5]\d):(?<second>[0-5]\d)|)/
str = '21.10.2013'
# Print the match result
str.match(re) do |match|
puts match.to_s
end