re = /(<a.*href=)["'](.*)["']/m
str = '<h2><a href="http://www.google.com/test">Link</a></h2>2014-54-22 22:23'
subst = '\\1"http://localhost/down.php?u=urldecode(\\2)"'
result = str.sub(re, subst)
# Print the result of the substitution
puts result