$re = '/^(?!.*réunion).*\R/im';
$str = 'https://regex101.com/réunion
https://reréuniongex101.com/
https://regex101.com/réunion
https://regex101.com/réu
https://regex101.com/réunion2
réunion
réunion/aaaaa
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;