import Foundation
let pattern = #"^(?!.*réunion).*\R"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
https://regex101.com/réunion
https://reréuniongex101.com/
https://regex101.com/réunion
https://regex101.com/réu
https://regex101.com/réunion2
réunion
réunion/aaaaa
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)