$re = '/(?<=,)[^,\n]*|[^,\n]*(?=,)/';
$str = 'This is not successful
This,is,successful
,is also successful
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);