re = /(?<=,)[^,\n]*|[^,\n]*(?=,)/
str = 'This is not successful
This,is,successful
,is also successful
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end