import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\D*\\d+\\D*\\K\\d+";
final String string = "Hello 10 love 20 haha 30\n"
+ "Hello Hello 11 love love 21 haha 31\n"
+ "41 Hello Hello 42 love love 43 haha 44";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}