re = /^\D*\d+\D*\K\d+/m
str = 'Hello 10 love 20 haha 30
Hello Hello 11 love love 21 haha 31
41 Hello Hello 42 love love 43 haha 44'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end