$re = '/(?<opening>\<\w)|(?<closing>\<?\/\w*\>)/';
$str = '<div Id=\'topDiv\' Class=\'randomClass\'><p Id=\'topP\' Class=\'randomParagraph\'></p>Blah<span></span>lkj<div Id=\'blahyay\'  ><div></div></div></div><div />';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);