const regex = /^https:\/\/.*\.pizzahut\.com*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^https:\\\/\\\/.*\\.pizzahut\\.com*', '')
const str = `https://leda.pizzahut.com
https://www.pizzahut.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}