re = /^https:\/\/.*\.pizzahut\.com*/
str = 'https://leda.pizzahut.com
https://www.pizzahut.com'
# Print the match result
str.match(re) do |match|
puts match.to_s
end