#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:.*\/)(.+)\.(.+)"
Local $sString = "a/b/c/d/file1.c" & @CRLF & _
"a/b/c/d/e/f/g/h/1/2/3/4/5/foo.c" & @CRLF & _
"dir1/dir2/newlinedir" & @CRLF & _
"/nextlinedir/bar.c"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")