import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:.*\\/)(.+)\\.(.+)";
final String string = "a/b/c/d/file1.c\n"
+ "a/b/c/d/e/f/g/h/1/2/3/4/5/foo.c\n"
+ "dir1/dir2/newlinedir\n"
+ "/nextlinedir/bar.c";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}