using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^CN=([a-z0-9\-]+),.*";
string input = @"CN=DQF4133,OU=Utilisateurs,OU=Desjardins,DC=mvt,DC=desjardins,DC=dev
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}