$re = '/^CN=([a-z0-9\-]+),.*/i';
$str = 'CN=DQF4133,OU=Utilisateurs,OU=Desjardins,DC=mvt,DC=desjardins,DC=dev
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);