const regex = /(http(s)?:\/\/)?(www.)?(formable\.se(?!\/almega)\/\S*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(http(s)?:\\\/\\\/)?(www.)?(formable\\.se(?!\\\/almega)\\\/\\S*)', 'gm')
const str = `formable.se/xxxx122..44442xxxxxx gfgdff
http://www.formable.se/almega/xxxx122..44442xxxxxx gfgdff`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}