re = /(http(s)?:\/\/)?(www.)?(formable\.se(?!\/almega)\/\S*)/m
str = 'formable.se/xxxx122..44442xxxxxx gfgdff
http://www.formable.se/almega/xxxx122..44442xxxxxx gfgdff'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end