const regex = /^(?:[\w\d\.-_])+@(?=.{4,64}$)(?:[\w\d]+[-]?[\w\d]+\.|[\w\d]\.)+(?:\w{2,})$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[\\w\\d\\.-_])+@(?=.{4,64}$)(?:[\\w\\d]+[-]?[\\w\\d]+\\.|[\\w\\d]\\.)+(?:\\w{2,})$', '')
const str = `q1.3bb@12345678901234567.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}