re = /^(?:[\w\d\.-_])+@(?=.{4,64}$)(?:[\w\d]+[-]?[\w\d]+\.|[\w\d]\.)+(?:\w{2,})$/
str = 'q1.3bb@12345678901234567.com'
# Print the match result
str.match(re) do |match|
puts match.to_s
end