package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d+)x(\d+)`)
var str = `1100x1200@60 or 800x600@25`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}