$re = '/(\d+)x(\d+)/m';
$str = '1100x1200@60 or 800x600@25';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);