import re
regex = re.compile(r".*\K<!--.*?stylesheet.*?-->", flags=re.DOTALL)
test_str = ("<!-- The quick brown fox \n"
" jumps over the lazy dog -->\n\n"
"<!--[if IE 7]>\n"
" <link rel=\"stylesheet\" type=\"text/css\" href=\"/supersheet.css\" />\n"
"<![endif]-->\n\n"
"<!-- Pack my box with five dozen liquor jugs -->")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")