package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`#=#=#[a-zA-Z]{5}\b`)
var str = `1-02948091jeknm,a sd,nbjwhu3hroLKjahefkljalsj#=#=#pesho
1gjq&&&geo*nhvjsfbsbdkfjq.311/.24/3.4,l2
3u827582929@@@@#=#=#gosho
&&&ped-&&&eraeesmdfjbdfspefkowekf
#=#=#
&&&
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}