$re = '/#=#=#[a-zA-Z]{5}\b/';
$str = '1-02948091jeknm,a sd,nbjwhu3hroLKjahefkljalsj#=#=#pesho
1gjq&&&geo*nhvjsfbsbdkfjq.311/.24/3.4,l2
3u827582929@@@@#=#=#gosho
&&&ped-&&&eraeesmdfjbdfspefkowekf
#=#=#
&&&
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);