using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\b[^,]+\b)";
string input = @" Monday,Tuesday, Wednesday ,Hello World , Lorem ipsum dolor sit amet , , a b c d e ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}