$re = '/(\b[^,]+\b)/';
$str = ' Monday,Tuesday, Wednesday ,Hello World , Lorem ipsum dolor sit amet , , a b c d e ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);