import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[^.@\\n]*\\.)?([^@\\n]+)(?:@.*)?$";
final String string = "nonpersonalizedusername004\n"
+ "nonpersonalizedusername019@domaina.local\n"
+ "prefixc.nonpersonalizedusername044@domaina.local\n"
+ "nonpersonalizedusername038@domainb.local\n"
+ "prefixa.nonpersonalizedusername002@domaina.local\n"
+ "prefixb.nonpersonalizedusername038@domainb.local\n"
+ "givenname.surname\n"
+ "givenname.surname@domaina.local";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}