re = /^(?:[^.@\n]*\.)?([^@\n]+)(?:@.*)?$/m
str = 'nonpersonalizedusername004
nonpersonalizedusername019@domaina.local
prefixc.nonpersonalizedusername044@domaina.local
nonpersonalizedusername038@domainb.local
prefixa.nonpersonalizedusername002@domaina.local
prefixb.nonpersonalizedusername038@domainb.local
givenname.surname
givenname.surname@domaina.local'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end