#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^([1-9]|[1-5]?[0-9]{2,4}|6[1-4][0-9]{3}|65[1-4][0-9]{2}|655[1-2][0-9]|6553[1-5])$)|" & @CRLF & _
"(^([1-9]|[1-5]?[0-9]{2,4}|6[1-4][0-9]{3}|65[1-4][0-9]{2}|655[1-2][0-9]|6553[1-5])-([1-9]|[1-5]?[0-9]{2,4}|6[1-4][0-9]{3}|65[1-4][0-9]{2}|655[1-2][0-9]|6553[1-5])$)|((?<=,|^)([1-9]|[1-5]?[0-9]{2,4}|6[1-4][0-9]{3}|65[1-4][0-9]{2}|655[1-2][0-9]|6553[1-5])(?=,|$),?)|((?<=,|^)([1-9]|[1-5]?[0-9]{2,4}|6[1-4][0-9]{3}|65[1-4][0-9]{2}|655[1-2][0-9]|6553[1-5])-([1-9]|[1-5]?[0-9]{2,4}|6[1-4][0-9]{3}|65[1-4][0-9]{2}|655[1-2][0-9]|6553[1-5])(?=,|$),?)"
Local $sString = "0" & @CRLF & _
"1" & @CRLF & _
"2" & @CRLF & _
"3" & @CRLF & _
"10" & @CRLF & _
"11" & @CRLF & _
"12" & @CRLF & _
"101" & @CRLF & _
"15887-12122,5564" & @CRLF & _
"1000" & @CRLF & _
"2789" & @CRLF & _
"8080" & @CRLF & _
"10000" & @CRLF & _
"12345" & @CRLF & _
"54321" & @CRLF & _
"65432" & @CRLF & _
"6556-4344" & @CRLF & _
"65333,5343" & @CRLF & _
"55343,2323-32344,0" & @CRLF & _
"64343-23234,43433,13233-2333," & @CRLF & _
"54545,555-54544" & @CRLF & _
"54545,555-54544" & @CRLF & _
"80,444,443441111" & @CRLF & _
"67891" & @CRLF & _
"65536" & @CRLF & _
"3332322332" & @CRLF & _
"65535" & @CRLF & _
"65536" & @CRLF & _
"65537" & @CRLF & _
"1a5" & @CRLF & _
"80,443,33333-232222" & @CRLF & _
"32424, 23424"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")