import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^([1-9]|[1-5]?[0-9]{2,4}|6[1-4][0-9]{3}|65[1-4][0-9]{2}|655[1-2][0-9]|6553[1-5])$)|\n"
+ "(^([1-9]|[1-5]?[0-9]{2,4}|6[1-4][0-9]{3}|65[1-4][0-9]{2}|655[1-2][0-9]|6553[1-5])-([1-9]|[1-5]?[0-9]{2,4}|6[1-4][0-9]{3}|65[1-4][0-9]{2}|655[1-2][0-9]|6553[1-5])$)|((?<=,|^)([1-9]|[1-5]?[0-9]{2,4}|6[1-4][0-9]{3}|65[1-4][0-9]{2}|655[1-2][0-9]|6553[1-5])(?=,|$),?)|((?<=,|^)([1-9]|[1-5]?[0-9]{2,4}|6[1-4][0-9]{3}|65[1-4][0-9]{2}|655[1-2][0-9]|6553[1-5])-([1-9]|[1-5]?[0-9]{2,4}|6[1-4][0-9]{3}|65[1-4][0-9]{2}|655[1-2][0-9]|6553[1-5])(?=,|$),?)";
final String string = "0\n"
+ "1\n"
+ "2\n"
+ "3\n"
+ "10\n"
+ "11\n"
+ "12\n"
+ "101\n"
+ "15887-12122,5564\n"
+ "1000\n"
+ "2789\n"
+ "8080\n"
+ "10000\n"
+ "12345\n"
+ "54321\n"
+ "65432\n"
+ "6556-4344\n"
+ "65333,5343\n"
+ "55343,2323-32344,0\n"
+ "64343-23234,43433,13233-2333,\n"
+ "54545,555-54544\n"
+ "54545,555-54544\n"
+ "80,444,443441111\n"
+ "67891\n"
+ "65536\n"
+ "3332322332\n"
+ "65535\n"
+ "65536\n"
+ "65537\n"
+ "1a5\n"
+ "80,443,33333-232222\n"
+ "32424, 23424";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}