using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[(b|i|u|h1|h2|h3|large|small|list|table|grid)\](?:((?!\[\/\1\]).)*?|(?R))*\[\/\1\]";
string input = @"[b]the problem is that my [i]regex[/i] stops at the [b]first matching closing tag[/b] instead of matching recursively as i [u]expect it to.[/u] [/b]
[i]regex[/i] stops at the [b]first matching closing tag[/b] instead of matching recursively as i [u]expect it to.[/u]
[a]ssss[a]sssss[/a]ss[/a]
[b]sss[/b]
[c]asdfasd[d]asdaf[/d]fasdf[/c]
[i]test test [i]as fd[/i]this should match the whole line[/i]
[i]test test[j]this should match the whole line[/j]test[/i]
[i] test [j]this should match the pair of 'i' tags and ignore the second 'j' tag [/i] [/j]
the below line should have three sets of matches: center, h3, and grid; it only matches the h3 and grid tags
[center][logo][/center][hr][hr][h3]header[/h3][/center][hr][hr][grid][row][cell][b]some label[/b][cell]: [date][/grid]
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}