const regex = /\[(b|i|u|h1|h2|h3|large|small|list|table|grid)\](?:((?!\[\/\1\]).)*?|(?R))*\[\/\1\]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[(b|i|u|h1|h2|h3|large|small|list|table|grid)\\](?:((?!\\[\\\/\\1\\]).)*?|(?R))*\\[\\\/\\1\\]', 'gm')
const str = `[b]the problem is that my [i]regex[/i] stops at the [b]first matching closing tag[/b] instead of matching recursively as i [u]expect it to.[/u] [/b]
[i]regex[/i] stops at the [b]first matching closing tag[/b] instead of matching recursively as i [u]expect it to.[/u]
[a]ssss[a]sssss[/a]ss[/a]
[b]sss[/b]
[c]asdfasd[d]asdaf[/d]fasdf[/c]
[i]test test [i]as fd[/i]this should match the whole line[/i]
[i]test test[j]this should match the whole line[/j]test[/i]
[i] test [j]this should match the pair of 'i' tags and ignore the second 'j' tag [/i] [/j]
the below line should have three sets of matches: center, h3, and grid; it only matches the h3 and grid tags
[center][logo][/center][hr][hr][h3]header[/h3][/center][hr][hr][grid][row][cell][b]some label[/b][cell]: [date][/grid]
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}