package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bرغد فؤاد عيسى التميمي\b`)
var str = `رغد فؤاد عيسى التميمي`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}