$re = '/<%.*?%>/';
$str = 'BLA BLA text text <%eval request("BLA")%> text text <%eval request("BLA")%> text BLA';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);