$re = '/(?<=~{)[^}]+/m';
$str = '""
"a"
"~{1}"
" ~{1} "
"a bc~{1}c d"
"a b~{1}c d"
"a b~{1wgsfgsegdfgrdgrd}c d"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);