re = /(?<=~{)[^}]+/m
str = '""
"a"
"~{1}"
" ~{1} "
"a bc~{1}c d"
"a b~{1}c d"
"a b~{1wgsfgsegdfgrdgrd}c d"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end