const regex = /{{(.*?)}}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('{{(.*?)}}', 'gm')
const str = `Lorem ipsum dolor {{variable1}}, sit amet consectetur {{otherVaraible}} elit. Iure facilis quaerat obcaecati tempore {{variable2}} praesentium, nisi culpa vero`;
const subst = `${$1}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);