use strict;
my $str = 'Lorem ipsum dolor {{variable1}}, sit amet consectetur {{otherVaraible}} elit. Iure facilis quaerat obcaecati tempore {{variable2}} praesentium, nisi culpa vero';
my $regex = qr/{{(.*?)}}/mp;
my $subst = '${$1}';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";