package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[[^][]*[^][\d][^][]*]`)
var str = `Tag1[aA], Tag2[55].AA[*], Tag3[A1];`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}