package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(0:\/|(\.\.\/)+uploads\/)`)
var str = `0:/abc
../../../uploads/test
0:/../../../../../uploads/test
0:./././bla
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}