$re = '/(0:\/|(\.\.\/)+uploads\/)/';
$str = '0:/abc
../../../uploads/test
0:/../../../../../uploads/test
0:./././bla
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);