$re = '/--?\b\d+\b/m';
$str = 'Check number -12 13 -13 14 -14 15 -15';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);