re = /"[^"\\]*(?:\\.[^"\\]*)*"(*SKIP)(*F)|\h+/m
str = 'text required name="first_name" label="First Name! $ , ." column="1/2"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end