$re = '/^[^:]+?(?=:)/';
$str = 'Y
[sudo] Password for user: Other Text here
even more text here: with more text';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);