re = /^[^:]+?(?=:)/
str = 'Y
[sudo] Password for user: Other Text here
even more text here: with more text'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end