package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[A-Z]{0,2,3}\d+`)
var str = `AAA1234
0000123
A000123
AA12345
A{0,2,3}1234
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}